SMTP authentication not functioning for email notifications

There is an option to have ASTPP send locally sendmail/postfix, but it does not seem to function at all.
I put in a bug report on that issue, and it is not making much progress.

Since you stated

It seems like you have the Sendmail option selected in settings, rather than SMTP selected.

For your line

There is no need for that. When postfix is installed, it already places a symbolic link.

Thanks for your reply.

I can’t find where else in ASTPP settings I can set SMTP instead of Sendmail.
My Installation is ASTPP V6 Community version, and the notifications settings looks like this:

Where SMTP option is either: enabled or disabled.

Also, I verified that there were no symlink created for postfix on my installation (for some reason), so I went ahead and just renamed the existing “sendmail” (usr/sbin) and created a Symlink “sendmail” pointing “postfix”. My php.ini has this line too: /usr/sbin/sendmail -t -i

I rebooted it, and still not able to send notifications. Also the logs, only “astpp.log” appears to be recording some info. The other log in ASTPP log directory (astpp_email.log) is still blank (0 bytes) since the installation of ASTPP.

When SMTP is enabled, trying to adjust postfix or sendmail is is not going to help. The system is then using a mail client from CodeIgniter. You will have to check the local logs, and the mail server logs on the mail server.

Only when SMTP is disabled, and notifications set to yes will it use sendmail or postfix.

I tried that too. Same results. I even hard removed (purge) both SENDMAIL and POSTFIX, and I re-installed POSTFIX only (from scratch). Then I configured the parameters in Postfix Master files, and mail service is working again perfectly fine, whenever I use it to send mail from any other application / program installed (even Fila2Ban is sending me alerts) using this postfix config.
It is just my ASTPP installation, it’s like it is doing nothing when I attempt to send notification from this program. SMTP is disabled in ASTPP settings, but with Email Notifications “enabled”, and nothing appears under any LOG (either, regular Mail logs, or /var/log/astpp/astpp_email.log (which is completely empty). By the way, regular Mail LOGS (/var/log/mail.log , /var/mail/mail.err, etc.) from my server are working as expected. They are being populated with info whenever I use any other application to send mails through this POSTFIX running service.

Not sure where else to look at to try to troubleshoot specifically ASTPP notifications. Maybe will work if I re-install Sendmail, I haven’t tried that yet, but it will require to reverse my hours of settings in Postfix. And at the end of the day, l won’t use Sendmail on this server anyway (I want to keep POSTFIX for production server).

I only use Postfix and it works just fine with that. No need to use Sendmail.

I know it is not functioning, and why I put in a bug report for the sendmail/postfix issue.

For SMTP, as I keep mentioning, the system is using a PHP email client which the maillog will never be populated from using that.

You will have to check the ASTPP logs, and the mail server logs to troubleshoot that.

A good starting point like I did was to test SMTP using Gmail.

Thanks guys for trying to help me with this.
I tried testing by using SMTP with Gmail too, didn’t work either, and no logs (related to ASTPP notifications and/or ASMTP using SMTP or Mail instruction) to troubleshoot at all.
I guess I am just giving up. I will keep this server without notifications from ASTPP for now (I will try to
use other mechanism for alerts, maybe a Cronjob)

KNERD, hope your bug report gets solved, keep us updated on this thread. Thanks.

That line you edited

Did you put it back to null when testing with Gmail?

Yes, that line had been restored (“null”) as it was, before some other tests I tried again for troubleshooting, including the GMAIL test.

Have you looked at the ASTPP email log?

Hello @KNERD

We tried to understand your concern as well as we also checked in our set-up.

I would like to share configuration steps as well as result of our execution.
open this link to verify your configuration : Sign in to your account

Even after doing any further activity after watching this video and still your problem is same as earlier then let me know here.

Another way can be : We would like check and fix problem directly on your server and for this activity your need to provide server access to us if this is convenient to you.


It’s not me having issue with SMTP, but rather @chamtest .

I put in a bug report for sendmail not functioning at all when you have notifications enabled, but SMTP disabled.