Why ASTPP is so useless

I’d like know how many people using ASTPP community edition without serious issue.

The system use obsolete linux distribution like centOS 7 and debian 10, php 7.3 (end of life), problem with reseller part, problem with installation script full of errors, command repeat more than one time…

The developers answer few time so I can’t know if is my error or a bug.

So my story with ASTPP ends here.

Good Luck

1 Like

…and the developers using the email you have to insert during installation script execution to SPAM you

Version 6 is suggested to use Debian 11.
For PHP 7.3, yes that is a problem as Debian 11 repo uses version 7.4, and there is significant change from 7.3 to 7.4 which breaks the database connection.

For FreeSwitch, I have tried compiling it for use with ASTPP and SIP profiles will not load from the database, and none of their people can even tell me what is going on there, nor what to look for to help fix it.

The quality of the application seems to be going down over time. If they would at least help cooperate , I would do some fixes myself, but you can barely get anything out of them. They also want people to help with the community addition with pull requests, but looking on github, they are ignoring them.

It should be fairly easy to update the code from 7.3 to 7.4. I just did it for another application. There are only a few changes that are not backwards compatible. Just need to search the code for those things.

To see where it is failing you probably need to enable PHP error logging.

/opt/ASTPP/web_interface/astpp/application/config/config.php > $config['log_threshold'] = 4

This will cause a date stamped log file to be created at

which shows all the PHP code being initialized and any errors in that code. This should only be enabled temporarily as the log files are not automatically deleted. There may also be some sensitive information in those files.

You can also go to

and set define ( 'ENVIRONMENT', 'development' ). This allows you to see the PHP errors in a web browser as they happen instead of just in the log files.

1 Like

@KNERD I compileted FreeSWITCH from the source and worked with ASTPP so I can Help You (maybe)

@sman123 I not have time to change, debug and solve… maybe the developers have to do this.

Now the big problem is:

[ERR] switch_utils.c:4584 Unknown message digest md5

on the FS console; no permit extensions registration. I have a same version FreeSWITCH and works fine. This error is relative to SIP Autentication but I don’t know how solve.



I started a thread, but they stopped responding. The SIP profiles are not loading from the database.

Thanks for those tips. I am working on a script to install everything from the distro’s repo. I was installing PHP 7.3 from the same third party repo because v 7.3 is not available on Debian 11 nor Ubuntu 22.04.

WHat is sad is they still continue to use a third part repo for Debian 10, even though 7.3 is available on its repo.

That is just being lazy to change the code, and now a lot of bugs in ASTPP 6 (which was just released) while they are already talking about releasing version 7 by the of this year.

I try to install ASTPP on rocky LInux 8 but without luck… many PHP errors I don’t know how Solve.

I can share a script to install ASTPP on CentOS 7 with FreeSWITCH from source… should be works.


I started a thread trying to get a discussion going on updating CodeIgnitor. That is what this project really needs. I’m pretty good at PHP and Javascript and have already done some work on this, but I don’t want to maintain my own fork.

1 Like

I’m beginning to think ASTPP is a died project. Sorry but I can’t spent more time with this.

It’s not dead, it’s just not very well managed, nor not very well developed.

Maybe they should of taken the FreePBX route. FreePBX is modularized. If you want to add abilities, you just add more modules. Some are open source, and some are paid commercial ones.

Instead they are screwing up the whole project with what I feel is terrible development, and trying to push people to their paid version. If the community one is not doing well, it does not give a good impression of people wanting to go to the paid version.

1 Like

The problem is that the core code, which is CodeIgnitor, is really old and needs to be updated. I don’t think the current core code will work with PHP v7.4 and v7.3 is EOL. So they don’t really have a choice.

1 Like

I saw they are not using MD5 nor seeding the password hash as you can see the passwords in the database in plain text.

I have tried running it on PHP 7.4 and it fails with some sort database connection issue. Something I would have to try to troubleshoot.

They use decodable passwords for UI login because SIP passwords need to be decodable and those are also used for UI access.

BTW, I think you need to enable legacy ciphers on Debian 11 because the one they use (BF-ECB) is not available by default.

1 Like

I have created a pull request to get ASTPP v6 working with PHP v7.4. Make sure to also edit the two nginx files for php7.4-fpm.sock.

Using v7.3, openssl_random_pseudo_bytes($ivSize) returns bool false because $ivSize=0, but with v7.4 it causes a fatal error. This fix makes it work the same way with both. Tested on Debian 11.

Is that backwards compatible with 7.3?

As previously stated, it works the same on PHP v7.3 and v7.4. Both were tested on Debian 11.

Yes, just making sure. Their script does install PHP 7.3 from a third party repo on Debian 11 so I was not sure if you made changes to continue to use PHP7.3, or PHP7.4

I am running my installer script now for PHP 7.4 then will make the changes manually once it is done.


I don’t use any scripts other than as a reference.

I also have PHP v8.1 working. It just needed a simple fix to get geoip working. I’ll submit a pull request after my PHP v7.4 pull request is merged.