Error 502 Error after Intallation of v5 in Proxmox

I get an error 502 Bad gateway after installation of ASTPP 5.0 completes in Debian 9.13
I have tried installing with web server, without web server, with fail2ban, without fail2ban but same error.
Is there anyone who has resolved a similar issue?

Debian 9 is EOL

Try with Debian 10. I had success with Debian 10 & ASTPP V5 .

I started with Debian 10 but the script doesn’t even run in Debian 10

Which script?

The script provided on astpp website for community version

I am not sure they have uploaded an updated script, but their script uses binaries from SignalWire which now requires the use a a token attached to your account you create on the SignalWire site.

I made a script for Debian 10 which instead uses the source code and compiles on the server.

Give mine a try

Thanks @KNERD I’ll try this and revert

Hey @KNERD it installed successfully and i was able to reach the web management page.


People who have been trying out the script have not been complaining, but I found a few bugs in the installation which I have fixed. They were related to FreeSwitch. You will have to do a reinstall, or figure out the things I changed.

Hi bmpalapala, what version of debian 10 did you use?


Hi, what version of debian 10 did you use?


That makes no difference as the script from iNetrix will update the OS before proceeding

HI, I used the debian version 10.9.0, and I followed the instructions that are on github, however it does not work.

Yes, sorry. I have noticed a few bugs in it which I have been working on the past three days. Give me a few more days, but hopefully I will have the last of them completed by tomorrow.

Ok, I understad you, Thanks and I’m waiting . Thanks

I made another version of the script. This other new version uses the SignalWire repos. The reason for the change is because of a problem with the ASTPP configuration files is not making FreeSwitch function correctly for some reason.

I was thinking maybe I had miscompiled FreeSwitch. I am getting the exact same result with this other version. It’s going to take a while to figure this out.

To also let you know, the official iNextrix/ASTPP installer is also now broken. Theirs uses third party repo from MySQL (I am using MariaDB from Debian without problem). The MySQL process won’t run. I have not looked deeply why this is the case.

ok bro, thanks