How to configure email server for notifications

Hi, I have installed the 5.0 using the install script on a clean Centos 7, then I found the email in Menu Email History, their status are “Not Sent”, however I cannot found any error/history under
/var/log/maillog or

May I know how to configure the email server properly in order to sending out email notifications?
(via another SMTP server maybe)


Hello @watoan

I am attaching below one video link for configuration of SMTP in ASTPP v5.

Please refer above and let us know if you will have any questions.

Thanks for your reply.

I could not found smtp settings under “Company Profile”, however I have already entered my smtp details in “Configurations” > “Settings” > “Notifications”, but I found emails are “Not sent”

That’s why I would like to know if anything else need to be done with the sendmail daemon on the server?


Hello @watoan

In Company profile only you can find to fill details of smtp.


Just FYI in case you didn’t already know, The SMTP settings are only for notifications. If you also want voicemail emails to use these SMTP settings you can add this feature.

Hi @tinku.keot
I have already filled my SMTP details but email not going out and I couldn’t see any log in the log files.

Hi @watoan ,

Can you check by clicking on SMTP Email Test , You will get the error.

Could you please advise where I can find the “SMTP Test” button?

In “Company Profile”, nothing related to SMTP

I am running Version 5.0 Community

@sman123 This is interesting. You should send PR to ASTPP main repo.

You can get the logs from /var/log/astpp/ directory. There should be mail log file. Check the logs in that and see if you can find any error/log.

There is no log. I’m having the same issue as in the video; there’s a button to test SMTP, which I assume is also the case in the Enterprise Version. I don’t think this is working at all; i have checked for hours and cant get t to work.

May want to try looking at maillog.

If nothing, then maybe a command line email test.

I also suggest removing sendmail and replacing it with postfix

Set the permissions to 777 on the log directory and the file just to eliminate that as a possibility.

I think you need to enable debugging at:
Configuration > Settings > Calls > Debug

For /var/log/astpp.log to start working.

To see PHP errors on your browser, set environment mode to development at:

define ( 'ENVIRONMENT', 'development' )