How to force caller number in SIP account?

Let me know where the error is;

The account “20202020” has a sip account “20202020”

SIP account “20202020” has “Caller number” field as “4040404040”

SIP account “20202020” completes the call by Gateway “XPTO” with field “Caller-Id-In-From” signed as “True”

In SNGREP I can see that the Caller ID is still account number 20202020 and not caller number 4040404040

How can I force the account caller number?

I only got it in two horrible ways

a) forcing the user on the softphone to use 4040404040
b) forcing on the gateway through dialplan

Where am I going wrong? This existed in Astpp 3.5, inside the account in the field “OUT Callerid Translation”, where we would put “20202020/4040404040”, this was a fantastic function that I don’t see in version 5.0, or I don’t know how to proceed.

Can you please let us know what flow you are trying ?
Is it inbound call or outbound?
Also if possible please share freeswitch logs of the call.

You can force called id from SIP device settings.

SIP Devices - Edit SIP Devices - Caller Number (The Called ID Which you need to send in outbound calls)