Something seems to be not functioning in Community version (database writes)

Suggested information to share before you create new post/topic.

  • ASTPP Version (EG. 4.0.1 or 5.0) 6
  • Any modification have you done in default ASTPP : None
  • Operating System: (Debian X or Centos X) Debian 11
  • For call log sharing you can easily share on
  • Any other information like error logs, access log, service statuses, steps of reproduce etc.

I have been working on my own install script using PHP 7.4, and using MariaDB.

One issue I saw upon installation is one of the first things I try to do is set up a gateway with a provider.

The issue is it appears the info for the provider is not being saved/written incorrectly

Using WebMin, I tried looking at the table

As you see, Where the data should be going in gateway data , a 0 (zero) is being placed. The top one is the example one which is placed during installation.

Thinking it could be an issue with my installation related to MariaDB, I tried the following combinations:

  • MySQL instead of MariaDB
  • PHP 7.3 instead of PHP 7.4 with MariaDB
  • PHP 7.3 with MySQL

With all those failures I went back to the iNextrix install script.

I am now getting the identical results even with your script.

Scouring the logs, I am not seeing any errors, warning, or indications of something going wrong.

Mind taking a look at this?

I put in a bug report

Hello @KNERD ,
Currently whatever the issues you are facing, its because of php version.
Team is working with upgraded version of php.

@palak The iNextrix script installs version 7.3, are you saying that ASTPP version 6 no longer supports that?
And version 7.4 I have been testing is also not supported?

What version does it support now?

@KNERD ASTPP v6 will support version 7.3 of PHP version. Now we are working on upgraded php version to use in future releases.

@tinku.keot That’s that reason for me opening a ticket. I said I used the iNextTrix installer (which uses PHP 7.3) and I am getting the same write fails.

@KNERD Do you mean you have php version 7.3 and still gateway is not getting save ?

@tinku.keot That is correct. The results are posted in the images above. The gateway name is saved, but not the rest of the data.

@KNERD Okay we will check at our local setup and update you ASAP.

@tinku.keot thank you kindly.

I have tested on a local VPS and a cloud server on Debian 11, and getting the same results with the iNextrix installer.

If you want an easy database browser UI try Adminer. It’s just one file. Just plop it in the root folder of the ASTPP web directory and browse to it.

You need a barebones install with just the OS and nothing else. If you are using Webmin then it’s not a standard install because Webmin alters the server. I never see the stuff you see so it must be something to do with the way you are installing it.

I do install a barebones. It is only after I see issues, I start installing extra stuff to see what is going on, and why it does not function correctly.

If I am installing incorrectly, then blame it on INextrix with their install script.

I also have so-called “version 6” installed on a local test VPS from a few months ago. It seems to be working fine.

With that, I do see there have been some more recent updates to the community version about four months ago on GitHub. Perhaps that could be the reason for the problem.

@KNERD Install vanilla ASTPPv6 using latest installations script which is having sudo package related modification applied, it will install mysql db and configure, interconnect components as needed and you will not have the issue mentioned. Share your findings afterwards.

@devangn ev I did all that, and the writes to MySQL is still having issues. I did mention I used the iNextrix installer script also with the same results.

Try one more time. Don’t apply anything in the server before installation, don’t apply anything after installation.

I have two VPS I have tested this on. One on a local PC using Oracle VirtualBox, and another on SSH Nodes. Same results, unless some sort of update has been made since I posted this message. Otherwise I got the same results for both.

Freeswitch does not use MySQL by default. It uses SQLite. I gave more details in another thread and I also pointed this out to you before at least one other time. Unless the install script configures that. I don’t use the install script so I’m not sure.

Regarding errors in the logs. I would not get too distracted by them. Most are probably not related to your problems and may be completely benign, as in nothing to worry about.

1 Like

Until you upgrade the ancient obsolete (end of life for about 10 years now) highly insecure version of CodeIgnitor used in Community Edition I consider it abandonware. Doesn’t matter what version number you give it or what PHP version it can run.

You didn’t even bother applying minor updates to that old version of CodeIgnitor, which included several security updates, so I consider ASTPP Community edition to be very insecure right now.

It is configured to use MySQL during setup. I can confirm this in a.functioning test install from maybe 4-5:months ago using their script.

Also, even using my own script based on theirs, i can see info be put into mysql (or mariadb), but the gateway data is incomplete or.missing while the name of the gateway given remains. I think a bug may have been introduced recently

No changes within 4-5 months applied which might relate with this concern, that is you may confirm from merges @KNERD