UK Ringtone in freeswitch config

Hello everyone.
hope all doing fine. is there any possible by freeswitch configuration so when i make calls from my dialer it will be not show the original ringtone of the receiver instead it will be playing UK ringtone? i have a supplier account and strange when i call to ireland number i hear international ring tone.
anyone help please?


I do believe it is a .wav file playing

You may get reference from
and set the data value to uk-ring=%(400,200,400,450);%(400,2000,400,450)
for UK ringback

1 Like

Thanks a million.
But in which section we can apply in astpp? As you know I am using astpp and I want to know where we can add this Information?

Is it in sip profile we need to add?

Or in the gateway variable section?

Or need to go in freeswitch files?
If it’s in freeswitch file the can you please give me the exact location of the file.


Since there is nothing in ASTPP for that setting, you will have to configure it in FreeSwitch configuration.

Can you please give me a guide where to write in the freeswitch settings? Thanks for help anyway

i can’t find any place in astpp where i can add this. can you please tell me which file in the freeswitch configuration i can input this?

I think in the past week you could of read up on the FreeSwitch documentation to learn more about it to know what to do.

Hello sir
after a long time i am replying this. i checked in the vars.xml file there is about over 20 country ring there… but didnt wrote anywhere where i need to change it.

its basically sip to sip call i am getting a strange ring tone. can you please little more guide about it

Dig deep under scripts/astpp/scripts/