ASTPP 4 - Outbound calls error 403 Missing P-Asserted-Ide

Hi All,
I am working with some outbound providers and they require P-Asserted-Ide to be presented when making an outbound call. I can see the sngrep is giving the error saying that 403 Missing P-Asserted-Ide
one of the expert suggested to try and use localization which we have tried and it does not present the calls.

I will appreciate if someone can point me to the right direction to resolve this issue.
logs attached for reference. trace_Asttp_logs_17_05_2022 -
Please do let me know if you need anymore info and I can provide you.

@voicecloud you can refer below link from freeswitch

Thanks @tinku.keot for the quick reply.
Can you please advise, how can we make this change from ASTPP GUI is there any option I was thinking that could be by modifying Caller-id-In-Form True ?
I would appreciate if you could guide me, please.

Can do it on GUI of ASTPP or do i need to do it via the command line by modification of any scrip in freeswitch?

Many thanks

@voicecloud This you need to do from backend in freeswitch.

Any chance this can be modified by GUI ? looks like a bug as we are sending this via GUI right?
In fusonpbx we can set in in the gateway in advanced settings like this

If this is going to be chargeable can I get a quote for this please ?

No , thus is not bug.
For now your freeswitch is using Remote Party ID
which needs to change in backend in freeswitch to P-Asserted-ID.

Thanks for confirming that this is not a bug.
can you please guide me on how to modify this on freeswitch directly any document it will be a great help
Many thanks for the quick response. :slightly_smiling_face:

@voicecloud can you raise one ticket on ASTPPCOM from jira.
As I mentioned this needs little changes in freeswitch level , So ASTPP team will let you know on this.

Thanks @tinku.keot I have raised the ticket

@voicecloud Okay