Debian 11 Install Script MySQL not working

hello im trying to setup the v6 on debian 11 and the script cant install mysql what to do or solve tis ?

Install sudo then run install script.
apt install sudo

Problem is MySQL is NOT included in Debian anymore.

Try looking any errors the script is displaying.

thanks for the info guys, installed on debian 10 and it worked now testing. will get back to 11 to see if i can make it work there.

Hello @garias,
In debain11 OS in which you need to select repository “debian buster” and then for configuration part please select “OK”. Please find attached screenshot for your reference.

I thought I am the only one having this issue, Does anyone have a work around for this?

How do you get this screen to appear so you can select debian buster? When I run the install script it does not show this at all.

1 Like

It comes up automatically, but as mentioned, there is probably an error and help us help you by showing any error. Just saying “it don’t work” is not helpful, nor useful.

Hello @kevinboddy,

This option will pop-up automatically, we need to select the “debian buster” repository which is supported by our system and to configuring mysql-apt-config we need to select the “ok” and it only comes when you are using Debian 11 os.

You guys should change the install script to use MariaDB. Maybe consider that for v7. It only requires minor changes to the *.sql files. There is a good reason Debian uses MariaDB instead of MySQL by default now. I have tested ASTPP on MariaDB it seems to work just fine.

So then it seems my problem the SIP profiles not loading with my compiled FreeSwitch is not a database problem after all.

It works for me on Debian 11 but I don’t rely on scripts, don’t use MariaDB, and don’t compile Freeswitch from source.

This is how I install MySQL.

cd /opt && wget
dpkg -i mysql-apt-config_0.8.24-1_all.deb

# Select "Use Legacy Authentication" when asked
apt update && apt -y install mysql-server mysql-connector-odbc

My personal preference would be to use MariaDB but since this project insists on using MySQL v8 I just use that instead of having to edit the *.sql files.

I do the script for many reasons.

Don’t have to keep copy pasting the commands to test.
Provide an alternative to the one they provide and they are making it harder to get to it.

Looks like the script needs to be updated as it calls for sudo in some places. I also had this problem and removed sudo in the script. The installation worked but with bugs.

I then installed sudo and everything working well now. But you still will have to install odbc connector

apt install sudo

run the script

apt install mysql-connector-odbc

Yeah, I have noticed their coding keep getting sloppier.

I would love to create some modules for ASTPP. Maybe even add some PBX features. CodeIgnitor is fairly easy to work with and I like the ASTPP UI. However, I don’t want to do it when the core software is running an ancient EOL version of CodeIgnitor. Instead of changing version numbers for no apparent reason they should be updating that core software and cleaning up some of the sloppy code. I could certainly help but only if I see some indication they are willing to get on board with it.

1 Like

Just tried to do a new install on Debian 11 and I can confirm that the option to select the Debian Buster repository does NOT pop up at all. I did it twice and both times I got the second screen right away. Since this post is almost one year old, I can’t believe the script hasn’t been fixed.

It’s not the script rather the MySQL repo. You have to select Debian 10 for it.

I made my own script using MariaDB.

FYI. Astpp script installed fine on Debian 10.