[ERR] switch_utils.c:4584 Unknown message digest md5

What is this error in ASTPP??
It is appearing each time I make some adjustment in configuration, and avoids SIP endpoints to register.
I already confirmed if maybe my SIP passwords were wrong(they are OK).

@PALAK suggested a tricky way to solve problem for a few minutes:

  1. Run * fs_cli -x ‘fsctl shutdown elegant restart’ *
  2. Wait a seconds and endpoints are able to register(MD5 error goes away)
    …but then, if I need make adjustments to configuration, eventually the error re-appears…

Please help.!

if your LInux distribution is CentOS 7 change to Debian or leave ASTPP

1 Like

Hello @urbanet ,
What changes did you make and it came again, please share screenshot for it.

Dear @PALAK, I didn´t made any change, except normal configurations using ASTPP WEB access( create accounts, create SIP devices, trunks, etc etc). So, I don´t think the error mentioned(referred to MD5) could be caused for some change made by me.
I discovered today, the error appears only when SIP accounts are created in ASTPP; if I disable SIP accounts, the error dissappears; the error appears again if I re-enable some SIP account…
…I think this issue is related with something with the user/password…I´m not sure.
(next message contains a screenshot)

@social I´m thinking about…appreciate some alternatives suggestion

Hello @urbanet ,
Please let me know if you have installed PBX? DId you enabled opensips in GUI ?

Hi @PALAK; I installed ASTPP6 using ther script provided for developers; no changes, no compilation, no source code manipulation…nothing.

Hello @urbanet ,
This is freeswitch issue we have checked with developers, but it will take time for them to check what is the issue with freeswitch as its not related to ASTPP.


Is not true because I have a FreeSWITCH same linux distribution and same version and works without this issue.

Dear @PALAK, let me agree with @SOCIAL; the issue appears when ASTPP receives some registration(or re-registration) from some SIP device directly, AND WHEN THE ORIGINATING IP ADDRESS IS NOT IN THE LIST OF ALLOWED IP´s (under <Accounts/Customers/SIP Devices>); if the originating IP is in the list, then the issue does NOT occur…so, the issue depends on how ASTPP is managing permissions or registrations…

Maybe you could suggest: “ok, add the IP to the list and the problem is solved”… sadly, no…because I have multiple SIP endpoints originating from the same IP(my freePBX); adding the only freePBX IP to the list, avoids individual identification of each endpoint…ASTPP charges calls to only one account, instead recognize each endpoint.
(i hope my explaination clarifies the issue… thanks!)

My particular problem with this issue

Hello @urbanet ,

Can you please remove core.db of freeswitch then restart freeswitch. Then please monitor it.

Hi @PALAK. ok, done…

  • removed “core.db” file and restarted FS and ASTPP…result: SAME ISSUE.
    …screenshot below…
    …really: Am I the first one with this issue? Am I the only one in the world with this issue???

Hello @urbanet
can you please log this over → https://jira.astppbilling.org/ and share the details so we can check the error.

@urbanet I have the same issue using freeswitch repo or compiling from sources so the problem is ASTPP. My personal opinion: leave this project. This is only one of the problems ASTPP has. Regards

@urbanet if you can share your ssh information with us then go ahead and share it on samir.doshi@inextrix.com, we would like to dig into that. We are not able to reproduce that issue in our environment.

@smrdoshi really, THANKS.!
email with credentials has been sent to you.
Details, network diagram and a brief of our infrastructure sent too.

I´m very pending of your connection.


Hello @urbanet,

This is to update you that we have successfully connected to your server and we also monitor the fs_cli logs but we couldn’t observe such error while we are monitoring it. We have also tried to register the sip device and it was failed to connect and not received any logs in fs_cli. To reproduce the issue we need your support. Please contact my skype id below :


Hello @urbanet,

Thank you for connecting and cooperating to regenerate the error " [ERR] switch_utils.c:4584 Unknown message digest md5". We checked together and fixed the error and you also have confirmed from your end.

Here is summary of the steps we performed to overcome an issue:

Step 1: yum update openssl-devel
Step 2: cd /var/lib/freeswitch/db/ and take backup of core.db
Step 3: rm -rf core.db
Step 4: systemctl restart freeswitch
Step 5: systemctl restart php-fpm
Step 6: Go to fs_cli and run reloadacl and reload mod_sofia