New installer script with no third party repos


With a little delay, I finally have a beta of my installer script for ASTPP version 5 ( on Debian 10, and 11 only at this time).

It is still in beta because while, the script itself it functioning fine, there seems to be some sort of incompatibility going on with ASTPP, and I am not sure what the cause is yet.

There are two branches, a main, and testing.
The main is the script running as it should, and a testing which will stop the script between sections so one can evaluate the output of the script to check for issues before going on to the next section of installation.

The issue is upon initial login:

An Error Was Encountered

Length must be greater than 0

The error is coming from the file: /opt/ASTPP/web_interface/astpp/system/core/Common.php

The whole function is here:

if ( ! function_exists('show_error'))
        function show_error($message, $status_code = 500, $heading = 'An Error Was Encountered')
                $_error = & load_class('Exceptions', 'core');
                echo $_error->show_error($heading, $message, 'error_general', $status_code);

Here is the script location on GitHub

Maybe someone at iNetrix, or another could help shed some light on why this error is coming up.
There is nothing else in the logs.

@KNERD I think the issue due to your changes in our script and its related to something about database.Kindly have look in your changes , There may be something and that is the way to fix this.

In the astpp-5.0.sql script, I had to change

/*!50003 SET collation_connection = utf8mb4_0900_ai_ci */ ;


/*!50003 SET collation_connection = utf8mb4_unicode_520_ci */ ;

MariaDB was throwing an error when it got to those lines. After making the change which was suggested, the errors went away. Looking at the database, all the initial data seems to have been properly placed into MariaDB.

@KNERD As our script tested and mysql will correctly installed without those parameters.
Can you please look into it which your changes started throwing the error?It will help to get into it.

It seems that the error only occurs when using Debian 11, when I tried Debian 10.12 the script worked perfectly.

The only difference between the two is Debian 10 is using PHP 7.3, while Debian 11 is using PHP 7.4.

Unlikely, as I have never tested the script with Debian 10 until today. I spotted two problems because I am not using third party repos iNetrix is using.

  1. By default, Debian 10 has iptables version 1.8.2 in its repo. There is a long time bug still in that version, thus iptables is not functioning correctly. One has to use Debian backports to install version 1.8.3.

  2. Monit is also not in the Debian standard repos so Debian backports must again be used to install it.

I made a few changes after running into errors I listed above for Debian 10.

As of now, it seems Debian 10 is fully functioning now.

If anyone wants to give it a try for Debian 10:


Debian 11 is still not resolved. As previously mentioned, the major difference between Debian 10 and 11 is PHP v7.3 vs PHP v7.4,

Since the error is coming from the ASTPP code (source listed above), maybe you can provide some input on what sort of issues would cause the ASTPP code to throw errors?

Remember, this script only uses Debian repos, and source code available from SignalWire’s FreeSwitch, and iNetrix’s ASTPP. This way, there is no need for a SignalWire token, MySQL repos, nor Remi Repo.

Hello friends, is the script already fully compatible with debian11? Congratulations

The script is not the problem. There seems to be a compatibility issue with ASTPP v5 , and Debian 11. I have not had time to see what the issue is. Perhaps it is PHP versions.

Debian 10 is fine.